Установка OwnCloud 8 в Openmediavault (без плагина)

Список разделов Openmediavault по-русски Плагины

Описание: Установка и настройка плагинов в OpenMediaVault.
Здесь обсуждаем и задаем вопросы только по дополнениям и плагинам.
Модератор: Major

#21 i779 » 14.01.2016, 12:49

Пробовал кто нибудь установить owncloud с помощью установочного *run от bitnami ? у меня на xubuntu установилось за 3 минуты и работает. Роюсь уже полчаса, не косячит, не жалуется. Нет возможности в ближайшее время на openmediavault попробовать, кто решится, отпишитесь как прошло.
i779
Репутация: 1
Сообщения: 8
С нами: 2 года 1 месяц

#22 Maxorol » 20.01.2016, 12:04

i779 писал(а):Пробовал кто нибудь установить owncloud с помощью установочного *run от bitnami ? у меня на xubuntu установилось за 3 минуты и работает. Роюсь уже полчаса, не косячит, не жалуется. Нет возможности в ближайшее время на openmediavault попробовать, кто решится, отпишитесь как прошло.
А ссылку не дашь? проверим
Maxorol
Репутация: 0
Сообщения: 7
С нами: 1 год 6 месяцев

#23 i779 » 20.01.2016, 15:31

i779
Репутация: 1
Сообщения: 8
С нами: 2 года 1 месяц

#24 alexicon » 21.01.2016, 10:27

i779, и что делать с *.run c bitnami.com? У OMV нет графической оболочки, только ssh
з.ы. нужно сделать
Код: Выделить всё
chmod 755 bitnami-application-version-linux.run
а потом можно запускать *.run
alexicon
Бывалый
Репутация: 15
Сообщения: 67
С нами: 3 года 9 месяцев

#25 Maxorol » 21.01.2016, 11:59

alexicon писал(а):а потом можно запускать *.run
поможешь? каким именно образом потом запускать run?

p.s
при попытке выполнения
Код: Выделить всё
chmod 755 bitnami-application-version-linux.run

невозможно получить доступ к "chmod 755 bitnami-application-version-linux.run" Нет такого файла или каталога

Добавлено спустя 1 час 9 минут:
В итоге он вроде установился, только я теперь не пойму, как в него зайти
Maxorol
Репутация: 0
Сообщения: 7
С нами: 1 год 6 месяцев

#26 alexicon » 21.01.2016, 13:46

Maxorol, открыть в браузере ip_adress_omv:порт_который_указал_при_установке_*.run
как устанавливать bitnami stack
alexicon
Бывалый
Репутация: 15
Сообщения: 67
С нами: 3 года 9 месяцев

#27 Maxorol » 21.01.2016, 14:41

Что-то видимо я не то делаю.
веб страница недоступна.
ip_adress_omv:порт_который_указал_при_установке_*.run
Вот этот "*.run " не нужен наверно в конце.
Maxorol
Репутация: 0
Сообщения: 7
С нами: 1 год 6 месяцев

#28 alexicon » 21.01.2016, 22:51

Maxorol, при перезагрузке установленный из bitnami stack ownCloud автоматически не стартует, его надо запускать руками, у меня например нужно выполнить
Код: Выделить всё
/opt/owncloud-8.2.2-0/ctlscript.sh start
вписал это в Запланированные задания
alexicon
Бывалый
Репутация: 15
Сообщения: 67
С нами: 3 года 9 месяцев

#29 svized » 25.02.2016, 18:20

пытался установить через репы -- ошибка. Вчера снова попробовал на прямую, не желает скачивать файл, никак

Код: Выделить всё

root@server:~# apt-get install openmediavault-nginx --fix-missing
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
НОВЫЕ пакеты, которые будут установлены:
  openmediavault-nginx
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 39,2 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 527 kB.
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
  openmediavault-nginx
Установить эти пакеты без проверки [y/N]? y
Ош  http://packages.omv-extras.org/debian/ stoneburner/main openmediavault-nginx all 2.4
  Что-то странное произошло при определении «packages.omv-extras.org:http» (-5 - С именем хоста не связано ни одного адреса)
Не удалось получить http://packages.omv-extras.org/debian/pool/main/o/openmediavault-nginx/openmediavault-nginx_2.4_all.deb  Что-то странное произошло при определении «packages.omv-extras.org:http» (-5 - С именем хоста не связано ни одного адреса)
E: Internal Error, ordering was unable to handle the media swap


что-то было укогонить???
OMV 3.0
Intel C2D T7200/iPox 2Gb/2 HDD 2Tb
svized
Бывалый
Откуда: Kiev
Репутация: 3
Сообщения: 62
С нами: 3 года 5 месяцев

#30 wishuwerehere » 25.02.2016, 19:39

стяни wget -ом, и установи
но походу у тебя инет есть на этой машине? а днс нормально резолвит?
wishuwerehere
Бывалый
Аватара
Репутация: 8
Сообщения: 76
С нами: 1 год 8 месяцев

#31 svized » 25.02.2016, 21:32

Таки какая-то проблема со скачиванием, wget тоже не качает

Код: Выделить всё
root@server:apt-get install php-apc
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Предлагаемые пакеты:
  php5-gd
НОВЫЕ пакеты, которые будут установлены:
  php-apc
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 90,0 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 254 kB.
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
  php-apc
Установить эти пакеты без проверки [y/N]? y
Ош  http://ftp.ua.debian.org/debian/ wheezy/main php-apc i386 3.1.13-1
  Что-то странное произошло при определении «ftp.ua.debian.org:http» (-5 - С именем хоста не связано ни одного адреса)
Не удалось получить http://ftp.ua.debian.org/debian/pool/main/p/php-apc/php-apc_3.1.13-1_i386.deb  Что-то странное произошло при определении «ftp.ua.debian.org:http» (-5 - С именем хоста не связано ни одного адреса)
E: Невозможно получить некоторые архивы, вероятно надо запустить apt-get update или попытаться повторить запуск с ключом --fix-missing

OMV 3.0
Intel C2D T7200/iPox 2Gb/2 HDD 2Tb
svized
Бывалый
Откуда: Kiev
Репутация: 3
Сообщения: 62
С нами: 3 года 5 месяцев

#32 Talug » 26.02.2016, 20:07

Пытался поставить с поддержкой MySQL. Ругается на гейт таймаут. Видимо установщику не хватает времени, заданного в nginx обработать скрипты базы. Куда копать, чтобы увеличить время обраотки скриптов? Пробовал менять время в пулах, но ему по моему пофиг.

Добавлено спустя 48 минут 9 секунд:
Впрочем со стандартной SQLite то же самое

Добавлено спустя 1 час 12 минут:
Решение - добавить строку
fastcgi_read_timeout 300;

после
location ~ ^(.+?\.php)(/.*)?$ {
try_files $1 = 404;

в дополнительных опциях сервера.

Правда все равно выдало таймаут, но с SQLite после перезапуска загрузило морду облака
Talug
Репутация: 0
Сообщения: 2
С нами: 1 год 4 месяца

#33 alexicon » 03.03.2016, 13:23

Должен отметить, что инструкция в первом посте топика это перевод инструкции с оф. форума http://forums.openmediavault.org/index.php/Thread/7609-Owncloud-8-and-MySQL-alternative-approach/?pageNo=1
alexicon
Бывалый
Репутация: 15
Сообщения: 67
С нами: 3 года 9 месяцев

#34 Maks » 03.03.2016, 18:31

Talug писал(а):Ругается на гейт таймаут
и у меня было подобное, полечил таким же способом - прописал руками fastcgi_read_timeout
посмотри здесь еще: http://homenas.ru/forum/viewtopic.php?f=7&t=552&p=4931#p4931
Maks
Репутация: 4
Сообщения: 28
С нами: 2 года 8 месяцев

#35 0dmin » 10.03.2016, 09:41

Кто-то уже обновился до 9ой версии?
BitFenix Prodigy Black + AMD E350 + 8GB DDR3 + 4TB + OMV 2
0dmin M
Откуда: Tyumen
Репутация: 6
Сообщения: 44
С нами: 2 года 8 месяцев

#36 Горин Роман » 13.03.2016, 19:58

Ставил 9-ку, без плагина так
Указывал и пробрасывал 90 порт
После установки и ввода логин/пас в базу
Бьет ошибку:
"Если вы являетесь администратором этого сервера, настройте параметры "trusted_domains" в файле config/config.php. Пример настройки можно найти в config/config.sample.php."

ищу решение


--

Добавлено спустя 1 час 51 минуту:
Решение найдено для ownCloud 9.0.0 (stable) :

при ошибке по адресу site.com:90/cloud/index.php
"Если вы являетесь администратором этого сервера, настройте параметры "trusted_domains" в файле config/config.php. Пример настройки можно найти в config/config.sample.php."

необходимо в конфиге - /media/dba05bbe/www/owncloud/cloud/config/config.php
указывать хосты без номеров портов
array (
'site.com',
'192.168.1.110',
),

а в мануалах указано, что порты обязательны, что есть ошибочно
array (
'site.com:90',
'192.168.1.110:90',
),

решение еще найдено тут

Добавлено спустя 34 минуты 5 секунд:
Найдены еще 2 ошибки уже в админке:

Предупреждения безопасности и установки

PHP был установлен неверно. Запрос getenv("PATH") возвращает пустые результаты.
Пожалуйста обратитесь к документации по установке для получения заметок по настройке php, а также к настройкам php вашего сервера, особенно это касается php-fpm.

Ваш каталог данных и ваши файлы возможно доступны из Интернета. Файл .htaccess не работает. Мы настоятельно рекомендуем Вам настроить веб сервер таким образом, чтобы каталог данных не был больше доступен или переместить каталог данных за пределы корня веб сервера.
Горин Роман
Аватара
Репутация: 0
Сообщения: 1
С нами: 1 год 3 месяца

#37 nwolf » 12.04.2016, 20:41

File not found. - пишет при коннекте.
что где упустил?
nwolf
Репутация: 0
Сообщения: 4
С нами: 1 год 3 месяца

#38 HMP » 19.04.2016, 14:14

Всё сделал по пунктам. Но при переходе на адрес сервера идёт длительное соединение и ничего не загнружает. В чём проблема ?

Добавлено спустя 1 час 36 минут:
Всё сделал по пунктам но при коннекте вот!
Изображение

Добавлено спустя 9 минут 27 секунд:
В чём же проблема всю голову сломал :(

Добавлено спустя 17 минут 11 секунд:
Проделал выше работу над ошбиками получил 403 Forbidden nginx/1.2.1

Добавлено спустя 1 час 33 минуты:
Подскажет кто?
HMP
Репутация: 0
Сообщения: 3
С нами: 1 год 2 месяца

#39 Honey12345 » 05.09.2016, 11:33

Установил последнюю версию owncloud 9.1.0 на OMV 3.0 Erasmus по описанной выше инструкции. Все отлично работает

Для устранения ошибок в админке owncloud добавте в расширенные опции пула строки:
Опции пула
env[HOSTNAME] = $HOSTNAME
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp

А в дополнмтельные опции сайта, добавьте (после тех строк что уже добавлены) следующую строку :

Спойлер
add_header Strict-Transport-Security "max-age=15552000; includeSubDomains";

До включения кэширования еще не добрался (:

Для включения кэширования ( я использовал вариант APCu), устанавливаем пакет php5-apcu:
# apt-get install php5-apcu

Перезапускаем наш web сервер.
В файл config.php который находится /media/(ваш идентификатор диска)/www/owncloud/config добавляем строчку :

'memcache.local' => '\OC\Memcache\APCu',

Заходим снова в админку и ошибок нет !!!
Honey12345
Репутация: 2
Сообщения: 6
С нами: 10 месяцев 8 дней

Проблема с размером закаченого файла

#40 evggusev » 09.10.2016, 21:53

Всем привет я на Erasmus поставил owncloud все работает! но есть одно но он не хочет загружать туда больше 10 гб. В инете есть отличный ман (https://github.com/owncloud/documentation/wiki/Uploading-files-up-to-16GB) все сделал по нему ну все равно не хочет больше 10 гб загружать. Может кто сталкивался? Ели нужны логи или конфиги все скину :cry: :cry: :cry:
evggusev M
Возраст: 27
Откуда: Санкт-Петербург
Репутация: 1
Сообщения: 2
С нами: 1 год 3 месяца

Пред.След.

Название раздела: Плагины
Описание: Установка и настройка плагинов в OpenMediaVault.
Здесь обсуждаем и задаем вопросы только по дополнениям и плагинам.

Быстрый ответ


Этот вопрос предназначен для предотвращения автоматической отправки форм спам-ботами.
:hi: :smile: :wink: :twisted: :sad: :evil: :smoke: :eh: :eek: :fie: :silenced: :razz: :oops: :help: :spy: :insane: :biggrin: :toothless: :ill: :nervious: :weirdface: :pray: :clap: :think: :boxing: :cyclop: :rambo: :zombie: :cry: Ещё смайлики…

   

Вернуться в Плагины

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 1 гость