Openmediavault 2.0 Stone burner

Список разделов Openmediavault по-русски Установка и обновление

Описание: Возникли проблемы при установке или обновлении системы? Все вопросы сюда.
Модератор: Major

#1 hobot-bobot » 03.05.2015, 09:16

Ветка развития OMV 1.x теперь получает только исправления ошибок. Новые функции будут осуществляться только в 2.x.
Спойлер
The 1.x branch of OMV will get only bugfixes from now. New features will only implemented in 2.x.

Для перехода на 2.x (Stone burner):
1) обновить до последней версии OMV 1.18
2) через консоль выполнить команду
Код: Выделить всё
omv-release-upgrade
3) почистить кеш в браузере!!!
Openmediavault 3.0 Erasmus linux-kernel-3.16 Intel Pentium G2010 2.8GHz 8Gb ОЗУ RAID6 7x2Tb
Изображение
hobot-bobot M
Автор темы, Администратор
Аватара
Возраст: 34
Откуда: Череповец
Репутация: 70
Сообщения: 1183
С нами: 4 года 7 месяцев

#2 dolboded » 10.05.2015, 11:17

что-то не хотит(
Спойлер
Traceback (most recent call last):
File "/usr/sbin/omv-mkaptidx", line 55, in <module>
cache = apt.cache.Cache()
File "/usr/lib/python3/dist-packages/apt/cache.py", line 102, in __init__
self.open(progress)
File "/usr/lib/python3/dist-packages/apt/cache.py", line 145, in open
self._cache = apt_pkg.Cache(progress)
SystemError: E:The value 'stable' is invalid for APT::Default-Release as such a release is not available in the sources
Reading package lists... Done
Reading package lists... Done
E: The value 'stable' is invalid for APT::Default-Release as such a release is not available in the sources
В репозиториях ничего добавлять не надо?

хм, хотя и на обычный apt-get update так-же реагирует
dolboded M
Аватара
Возраст: 27
Откуда: Ростов-на-Дону
Репутация: 6
Сообщения: 38
С нами: 3 года 4 месяца

#3 iriscell » 10.05.2015, 14:55

что-то не хотит(

нужно в /etc/apt/apt.conf

Код: Выделить всё
APT::Default-Release "stable";

поменять на

Код: Выделить всё
APT::Default-Release "wheezy";
iriscell
Репутация: 0
Сообщения: 11
С нами: 3 года 1 месяц

#4 Smile546 » 11.05.2015, 02:50

У меня не хочет обновляться. Вот что пишет :

root@NAS:~# omv-release-upgrade
Upgrading system to 2.0 (Stone Burner) ...
`/etc/openmediavault/config.xml' -> `/etc/openmediavault/config.xml.1x.bak'
Ign file: Release.gpg
Ign file: Release
Ign file: Translation-en
Ign file: Translation-ru
55% [Connecting to ftp.ru.debian.org (85.143.112.112)] [Connecting to security.debian.org (212.211.132.32)] [Connecting to packages.openmediavault.org (178.254.11.33)]

Добавлено спустя 6 часов 41 минуту:
Обновился до 2.06 (позже)

Добавлено спустя 8 часов 7 минут:
А еще позже снова попытался зайти через WEB- морду- ее нет. есть синяя заставка а там где логин и пароль вводится этого окна нет. Как вылечить?
Smile546
Репутация: 0
Сообщения: 45
С нами: 3 года 8 месяцев

#5 hobot-bobot » 11.05.2015, 19:55

Smile546 писал(а):А еще позже снова попытался зайти через WEB- морду- ее нет. есть синяя заставка а там где логин и пароль вводится этого окна нет. Как вылечить?
3) почистить кеш в браузере!!!
Openmediavault 3.0 Erasmus linux-kernel-3.16 Intel Pentium G2010 2.8GHz 8Gb ОЗУ RAID6 7x2Tb
Изображение
hobot-bobot M
Автор темы, Администратор
Аватара
Возраст: 34
Откуда: Череповец
Репутация: 70
Сообщения: 1183
С нами: 4 года 7 месяцев

#6 Smile546 » 11.05.2015, 21:06

почистил. помогло. Спасибо!!!
Smile546
Репутация: 0
Сообщения: 45
С нами: 3 года 8 месяцев

с 1.19 обновиться до 2.0.6?

#7 Юнин Денис » 16.05.2015, 11:13

Здравствуйте.
Подскажите пожалуйста. Стоит 1.19 версия. Не могу понять, как обновиться до 2.0.6?

Спасибо
Юнин Денис
Аватара
Откуда: Россия, Иркутск
Репутация: 0
Сообщения: 25
С нами: 2 года 11 месяцев

#8 Юнин Денис » 16.05.2015, 11:25

iriscell,

Нет такого файла у меня в 1.19.
Юнин Денис
Аватара
Откуда: Россия, Иркутск
Репутация: 0
Сообщения: 25
С нами: 2 года 11 месяцев

#9 Coolmax » 16.05.2015, 13:02

Кто перешёл уже на новую ветку, гляньте есть там плагины:
transmission
minidlna
plex
Coolmax
Репутация: 0
Сообщения: 6
С нами: 3 года 11 месяцев

#10 Smile546 » 16.05.2015, 20:32

omv-release-upgrade
Smile546
Репутация: 0
Сообщения: 45
С нами: 3 года 8 месяцев

#11 Vasom » 17.05.2015, 03:34

Coolmax, Все есть, только надо нужные репозитории включить в настройках OMV-extras.org
OMV 3.0.89. Intel Pentium G2120 3,1GHz 8Gb RAM. Системный SSD Silicon Power 32Gb. Суммарный объем дисков WD Red 10Tb.
Vasom M
Бывалый
Аватара
Возраст: 38
Откуда: Санкт-Петербург
Репутация: 23
Сообщения: 86
С нами: 2 года 8 месяцев

#12 fractal90 » 18.05.2015, 07:10

iriscell писал(а):нужно в /etc/apt/apt.conf

КОД: ВЫДЕЛИТЬ ВСЁ
APT::Default-Release "stable";

поменять на

КОД: ВЫДЕЛИТЬ ВСЁ
APT::Default-Release "wheezy";

Нет такого файла, установил 1.9

Добавлено спустя 4 минуты 13 секунд:
или 1.9 нельзя перейти? и стоит ли?
fractal90
Бывалый
Репутация: 0
Сообщения: 77
С нами: 2 года 11 месяцев

#13 iriscell » 18.05.2015, 11:07

fractal90 писал(а):Нет такого файла, установил 1.9

Добавлено спустя 4 минуты 13 секунд:
или 1.9 нельзя перейти? и стоит ли?
нужно сначала на 1.18 проапдейтить - хуже не будет (update manager -> check -> выбрать все -> upgrade)
по ощущениям, 2.0.7 ничем не отличается, может интерфейс чуть изменился
iriscell
Репутация: 0
Сообщения: 11
С нами: 3 года 1 месяц

#14 iriscell » 19.05.2015, 00:07

fractal90 писал(а):Нет такого файла, установил 1.9

можно попробовать в файле /etc/apt/apt.conf.d/99openmediavault-release заменить "stable" на "wheezy"
iriscell
Репутация: 0
Сообщения: 11
С нами: 3 года 1 месяц

#15 dolboded » 24.05.2015, 12:56

Юнин Денис писал(а):Нет такого файла у меня в 1.19.

Попробуй
Код: Выделить всё
etc/apt/apt.conf.d/99openmediavault-release
у меня так.

Всем спасибо, особенно iriscell, все обновилось
dolboded M
Аватара
Возраст: 27
Откуда: Ростов-на-Дону
Репутация: 6
Сообщения: 38
С нами: 3 года 4 месяца

#16 георгий » 28.05.2015, 02:07

а почему образа 2.х нет а только 1.х
георгий

#17 hobot-bobot » 28.05.2015, 12:49

георгий, потому что это практически одно и тоже, только нумерацию поменяли.
Openmediavault 3.0 Erasmus linux-kernel-3.16 Intel Pentium G2010 2.8GHz 8Gb ОЗУ RAID6 7x2Tb
Изображение
hobot-bobot M
Автор темы, Администратор
Аватара
Возраст: 34
Откуда: Череповец
Репутация: 70
Сообщения: 1183
С нами: 4 года 7 месяцев

#18 petrovichong » 02.06.2015, 15:44

Добрый день всем! У меня тоже 1.19 и нет в папке etc/apt/apt.conf.d/99openmediavault-release такого файла
Есть etc/apt/apt.conf.d/99openmediavault-localrepository, 99openmediavault-mkaptidx, 99openmediavault-norecommends, 99openmediavault-nosuggests .
И /etc/apt/apt.conf тоже нет М.. может неправильно что то встало, хотя вебморда работает и пишет что она 1,19 (Kralizec).
а да еще при установки зеркало не находил, я там сделал пропустить, мож из-за этого?
подскажите кто что может.
petrovichong
Репутация: 0
Сообщения: 2
С нами: 2 года 11 месяцев

#19 георгий » 03.06.2015, 01:35

у меня на трех машинах обновилось все хорошо с 1,18 -1,19 до 2,10 Но на одной когда поменял доменное имя отвалилась совсем сеть. Так что ставил с 0 быстрее и меньше сомнений. а вот одна удаленная стоит еще на 0.5.х даже боюсь ее удаленно обновлять :smile:
георгий

#20 petrovichong » 03.06.2015, 13:16

Ставлю с диска с 0! выдает ошибку на зеркало с архивом, выбрал Российская Федерация - ftp.ru.debian.org.
Хотя и на остальные тоже ошибка, пишет: выбрано неправильное зеркало... или проблема с сетью... или ошибка в файле Release - зеркало не поддерживает нужную версию Debian.
В чем косяк? если пропустить настройки то система ставится 1.9, после установки можно обновится до 1.19 и все кирдык дальше не хочет. в веб морде больше нет обновлений а через консоль смотрю у меня папка etc/apt/apt.conf.d/ а не etc/apt/apt.conf и в ней нет 99openmediavault-release.
что-то совсем не то. может у меня образ косячный, морда-же работает, плагины в ней видит можно поставить, пока не ставил. :cry:

Добавлено спустя 3 часа 17 минут:
Все! встал на другой винт :clap: косяк от 0,5 наверно?! щас плагины накатывать буду.
petrovichong
Репутация: 0
Сообщения: 2
С нами: 2 года 11 месяцев

След.

Название раздела: Установка и обновление
Описание: Возникли проблемы при установке или обновлении системы? Все вопросы сюда.

Быстрый ответ


Этот вопрос предназначен для предотвращения автоматической отправки форм спам-ботами.
:hi: :smile: :wink: :twisted: :sad: :evil: :smoke: :eh: :eek: :fie: :silenced: :razz: :oops: :help: :spy: :insane: :biggrin: :toothless: :ill: :nervious: :weirdface: :pray: :clap: :think: :boxing: :cyclop: :rambo: :zombie: :cry: Ещё смайлики…

   

Вернуться в Установка и обновление

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 1 гость